Thursday, August 28, 2008


Little Gratitude Towards The Flood Victims Of Bihar

When BIHAR is suffering from nature fury all these media’s are busy selling some cheap story. No one has shown their gratitude towards the people of BIHAR. If Rahul Gandhi tells that one person is suffering from drought, people start pouring money. When one singer dies entire Punjab cries. Having said this I did not mean any offence to these people. But why are we so insensitive towards the people of BIHAR? Are they all criminals ? They are also human being like rest of us. Media only like to sell the rape story. Media like to sell murder, kidnapping story from Bihar but why so unsympathetic towards the people of BIHAR. When people like Raj Thakery attacks north Indian Media makes him hero. Is he the sole protector of Marathi Culture ? Come on you can fool educated illiterate not educated literate. Everyone knows what game Raj Thakre is playing but media got masala to sell and made him hero. When Kashmir burns media makes people like Muhammad Yasin Malik as a hero. I have never seen what is the mystery behind Kashmir agitation? Yeah I am good in googling but still could not find the reason. Why we Indians are so insensitive towards human life? We have so many prominent leaders like Lalu sitting in government but never came forward to help people of BIHAR? My heart cries when I see so many selfish people in our country.
Coming back to Media where well dressed people sits in front of camera, hold the microphone and they just discussing anything and everything without knowing how it would help people who is suffering. Yeah they KNOW how to speak English. They are busy with Big brother and Jade Goody. Does every one think that Indian are poor? Are you kidding? India have billionaire and millioner in but just for themselves not for affected nation.
Why such natural disaster does not get people’s attention? Should we blame media or fate of those who is suffering? Should we blame people of Bihar who does not know how to tell their story to the entire nation/world?
GOD if you are really there I would pray to help those people who is suffering because of nature fury. Help my LORD to those people who are in field to help those suffering.

Now people who will read my blog will definitely ask me what you are doing? No dude I am doing it whatever I can, believe me and if you have any pointer let me know.

Please send your crossed cheque in the name "Chief Minister Relief Fund, Bihar" and post it to .

Secretary to Chief Minister.
Government Of Bihar
1 Anne Marg.
Patna 800001

Read this great effort by our CM Nitish Kumar.
NEW DELHI: The fury of Kosi, which struck east Bihar with a vengeance last Monday, may trigger one of the world's biggest human evacuations ever. The exodus should continue over the next several weeks with the scared population spread over six districts finally veering round to timely escape as the only option.

By now, almost one lakh marooned people have moved to safe highlands, bulk of them by government boats and many on their own. The reluctant trickle is now taking the shape of a torrent after an emotional appeal by chief minister Nitish Kumar, urging people to cut their losses and leave with their cattle.

At the time of reporting, over 10,000 people had beseeched the administration officials in Madhepura to take them to safety — a reversal of sorts since 24 hours ago, all the nudging could not make them leave their "ghar".

More such scenes could be witnessed in the next 48 hours if heavy rain, as forecast by the Met office, pelts the area, adding to the huge volumes of water gushing down from Nepal towards the plains of the ill-fated Bihar districts.

The deluge has, at any rate, presented a gigantic task of moving over 20 lakh people to protected zones. By Friday, the government expects to deploy 900 boats — motorised and manual — for evacuation work.

At an average of 100 people per boat, the daily shift could shoot to 90,000. The number of people voluntarily finding their way to safety will also continue to rise because they are slowly realizing that the worst of the Kosi crisis may not yet be over.

Friday, August 22, 2008

Another Mile Stone with P2V

I got an assignment to P2V old Dell hardware. Server was running critical application and was behaving wired. We planned to P2V this old guy. This old guy was running 4 CPU with 2GB of memory. It has NIC teaming as well (will tell latter what problem faced because of this).

I decided to do P2V using CD boot method (I did this in past and was quite comfortable with this). I called Datacenter folks and ask to check

1. It has CD ROM so that I can boot using Convertor ISO.

2. Machine has console access so that once machine get booted with CD.

Guys told it does not have any KVM Raritan connection or any remote management facility. I was kind of stuck and started reading blogs. I started looking at VC and finally I found plugin which was already available


I enable this plugin under installed tab and was trying to figure out how I will use it ☺ and will discuss this in detail below. I was planning how I would be going for this approach since this would be fist time I would be using “VMware Converter Enterprise”. I wanted to make sure that I am talking all the precaution so I got Mr. Eric Siebert’s for my rescue.

Precaution :a) Shut down all the un-wanted services.

b) Turn off the Antivirus.

c) Run ipconfig/all and make a note of all information about IP address.

d) Make a determination for amount of CPU or RAM which will go with virtual

machine while cloning.

Start Performing cloning physical machine:

1. Select the host where you want to place converted machine and right click on the host and select “import machine”. Now I got to understand where the plugin is working ☺


2. Wait till it does its magic clip_image006 and finally you get the screen where the magic (I am really excited with this new tool) start which will guide step by step


3. Select “next ” and choose the option as highlighted.


Note : Check rest of the option it give breathing space even for its rival ☺. This show how much VMware has respect for its rival as well. Can same honor will be given to VMware as well? I doubt.

4. Select Next and then provide the required information


5. It will try to connect and then prompt for option if you would like to install the converter agent on the remote machine. Also make a note that this agent install would reboot the remote host if it is running version below win2k. I usually select default one. Once you hit yes it will start installing agent. I have tested on my laptop and it freeze momentarily☺


6. It will bring the screen where it sees all the drive and give you the option to select for the P2V purpose. New disk space can be changed if required. In this case have to squeezed the space to 20GB from 75GB


Before I forget log for all these activity can be found under

C:\Documents and Settings\All Users\Application Data\VMware\VMware Converter Enterprise\Logs as vmware-converter-agent*

7. Select next, it will ask to double confirm the destination.


8. Hit next and it will ask for the virtual machine name. Same name can be given for which P2V is happening. Because we are going to shut down the physical and then power on this virtual. Also you can not select different datacenter.


9. Select next and it will ask for datastore where the VMDK or disk file will be placed. It will verify space availability and then proceed further with that.


10. Hit next and then it will detect the number of NIC. Here we can change the NIC which virtual server will have and what VLAN it should be going. Compare to standard converter this feature is cool because there were no way to change the VLAN(Don’t remember).


11. Hit next and it will prompt if you would like to install VM tools. My recommendation is do not install the VMtools at this point as it may conflict with other drivers.


12. Hit next and then select if you would like to do it now or schedule it for next sometime latter. I liked this feature which give me choice if I am trying to P2V some production machine.


13. Hit next and here you have the option if you want to “power on” the machine when P2V is completed. Select NO to be on the safer side because there is lot many “Post P2V” related activity.


Sit tight till it finishes up.


1. Once P2V is over we right click and select setting for the virtual machine


2. Remove all unwanted hardware because of P2V. Virtual just need base hardware as shown below. Also sometime if we are migrating windows2000 it will install controller as LSI logic but make sure buslogic is selected or else BSOD will be generated.


3. Once these cleanup is done then power on the machine with NIC disconnected. The reason I am doing this because actual machine is still powered ON.


4. Once these setting is done power on the machine and login with local admin and password. If there is any NIC teaming exist then break the team. The reason for this is NIC driver get migrated as part of P2V and if we uninstall driver without breaking this team than it may land up in additional troubleshooting.

5. These NIC driver are hidden when it is P2Ved. To do this go to a CMD prompt and type SET DEVMGR_SHOW_NONPRESENT_DEVICES=1 and then DEVMGMT.MSC and then select Show Hidden Devices. Delete any old grayed out hardware.

6. If you change from a multi-processor system to a uni-processor system you need to manually change the HAL on the Windows server after the conversion. To do this go into Device Manager after the machine first boots and discovers it's new hardware and then click on Computer then right-click on the processor and select Update Driver. Then select Install from specific location and then Don't search I will choose the driver to install. Then select show All compatible hardware and select the appropriate processor. For example, if you went from a dual cpu to a single cpu then select ACPI uni-processor PC instead of ACPI multi-processor PC. You will need to reboot once you change this. To verify what HAL you are using you right-click your hal.dll in c:\windows\system32 and select the Version tab and select Internal Name and it should say halmacpi.dll for multi-processor acpi and halacpi.dll for uni-processor acpi.

7. Next remove any vendor specific applications/drivers. For example on a HP server you should go to Add/Remove programs and remove any HP management agents, survey utility, array config utility, version control agent, etc.

Power On The Virtual Machine.

1. Shut down the physical machine. Make sure ping get timed out.

2. Install the VMtools on the virtual machine


3. Configure IP address on virtual machine and then connect the NIC.


4. Reboot the VM and when it is back mission should have been accomplished.

Converter Best Practices

Found this in the recently posted "Server Migrations with VMware Converter" presentation from VMware TSX and modified it based on my experiences

1. Agent Installation Location

• Locally: Install Converter and agent directly on source machine if converting directly into ESX Server

• Remotely: Connect to source machine over network to install agent

2. Agent Installation

• Use local administrator account

• Avoid domain accounts that have restrictive policies

• Allow reboot for Windows NT 4.0 and 2000 sources

3. Machine Preparation

• Do not deactivate services or harden security

    > Workstation service

    > Server service

    > TCP/IP NetBIOS Helper service

    > Volume Shadow Copy service (Windows 2003 or XP)

• Ensure sufficient free disk space (at least 200MB)

• Mirrored or striped volumes across multiple disks should be broken

• Dynamic disks with utility partitions should use cold cloning

• Disable Windows Simple File Sharing (Windows XP only)

• Disable anti-virus software

• Defrag hard disks

• Shutdown any un-needed Windows Services

• Clean-up any temporary files and un-needed data

• Run chkdsk

• Keep users off if possible

• Power off VM if not using hot cloning

• VCB VM exports need editing prior to import

    > Edit virtual disk filenames inside .vmx

    > Rename filenames for .vmdk files to match those listed in .vmx

    > Edit index .vmdk file to change references to span files

4. Network Preparation

• Open TCP/UDP ports 139, 445, and 902 (Converter 3.0.0) or 443 (Converter 3.0.1)

• Open network ports between source and destination

    > Alternative is to create a VM visible to source, copy VM files to location visible to destination, and import VM

• Use FQDN to connect to both source and VI3

5. Converter Preparation

• Run on OS greater than or equal to source if source is

    > VM and powered off, or

    > Symantec Livestate System Image

6. Cloning

• Starter edition limitations and workarounds

    > Cannot remote hot clone directly into VI3

         - Workaround 1: install Converter on source machine

         - Workaround 2: select standalone VM as destination, and then import VM to VI3 using two steps

    > Cannot run multiple tasks concurrently

         - Workaround: run multiple copies of Converter

    > Cannot cold clone

         - Workaround: create new VM, use third-party cloning application such as Ghost, and run Converter configure

• Do not resize volume for fastest clone speed (block-level copying)

• Resize volumes if source disks have inefficient utilization (resorts to file-level copying)

• Use cold-cloning disk-based cloning (not volume-based) for non-Windows systems

• Use hot cloning for Windows NT 4.0 systems to avoid NTFS upgrade

• Destination needs to be writeable

7. Configure

• Avoid cloning utility partitions

• Check partition numbers in boot.ini

• Automatic “Install VMware Tools” option is only available for ESX Server VMs

8. Clean-Up Prior to Power On

• Edit VM settings according to desired goal

    > Number of vCPUs

    > Add/Delete USB devices

    > Add/Delete Serial and parallel devices

    > Remove Floppy drive if not needed

    > SCSI controller type (BusLogic vs. LSI Logic)

• OEM source may require license activation

    > SMBIOS.reflectHost = “TRUE” in .vmx may avoid reactivation

    > Requires destination host to have same hardware

9. Clean-Up After Power On

• Detect hardware

    > VMware Tools installation may hang if hardware not detected

• Allow reboots to occur

    > Detect hardware and VMware Tools installation

• Verify HAL and change if necessary

• Remove non-present old hardware


    > Next type DEVMGMT.MSC and select Show Hidden Devices

    > Delete any old grayed out non-present hardware

10. Guest Troubleshooting

• Blue screen after powering on

    > Start Windows in Safe Mode and uninstall hardware-specific applications or services

    > Attach VM to “Helper VM” to remove hardware-specific drivers or to correct the boot.ini

• No keyboard/mouse

    > Select Workstation/Server VM instead of ESX Server, then import VM to ESX Server

    > Use PS/2 keyboard/mouse on source

• Display problems

    > Uninstall PC Anywhere prior to installing VMware Tools

Converter FAQ

What are the requirements for Converter?

For cold cloning the minimum memory requirements is 264MB, the recommended memory is 364MB. Converter uses a RAM disk while cold cloning and will not work with less then 264MB. Also the operating system on which Converter runs must be equal to, or greater, than the operating system on the source machine. For example if your source machine is running Windows 2003 and you are running Converter remotely, you must run it on a Windows XP or 2003 machine. You will not be able to run it on a Windows 2000 machine. If you run Converter on 2003 or XP you should be able to convert any operating system since they are the latest operating systems.

What platforms can Converter be installed on?

VMware Converter 3 can be installed on the following platforms: Windows XP Professional, Windows 2003 Server, Windows 2000 Professional, Windows 2000 Server and Windows NT SP6+ (IE5 or higher required)

What import formats does Converter support?

Source formats supported include: Physical Machines running supported OS, Microsoft Virtual PC (version 7 and higher), Microsoft Virtual Server (any version), Symantec Backup Exec System Recovery images (also Ghost 9 or higher), VMware Workstation 4.x virtual machine (compatible with VMware GSX Server 3.x), VMware Workstation 5.x virtual machine (compatible with VMware Player and VMware Server 1.x), VMware ESX Server 3.x, VMware ESX Server 3.x (when managed by VirtualCenter 2.x), VMware ESX Server 2.5.x (when managed by VirtualCenter 2.x)

What export formats does Converter support?

Destination formats supported include: VMware Workstation 4.x virtual machine (compatible with VMware GSX Server 3.x, ESX Server 2.5.x), VMware Workstation 5.x virtual machine (compatible with VMware Player and VMware Server 1.x), VMware ESX Server 2.5.x (when managed by VirtualCenter 2.x), VMware ESX Server 3.x (when managed by VirtualCenter 2.x), VMware ESX Server 3.x Note: VMware ESX Server 2.5.x when managed by VirtualCenter 1.x and VMware ESX Server 2.5.x unmanaged are not supported

What are the supported guest operating systems?

The following 32-bit guest operating systems are fully supported by VMware Converter 3: Windows NT, Windows 2000 Professional, Windows 2000 Server, Windows XP Professional, Windows 2003 Server

The following 64-bit guest operating systems are fully supported by VMware Converter 3: Windows XP Professional, Windows 2003 Server

Support for the following guest operating systems is Experimental. VMware Converter 3 can clone source images containing these operating systems, but the destination virtual machine may or may not work without additional configuration after import. In particular, if the source image contains unsupported hardware, you may need to modify the configuration of the destination virtual machine before using it: Linux, Windows NT 3.x, Windows ME, Windows 98, Windows 95, MS-DOS

What TCP/IP ports are used by Converter?

Converter 3.0.0 uses the following ports:

• Converter application to remote physical machine - 445 and 139

• Converter application to VirtualCenter Server - 902

• Converter application to ESX Server 3.x - 902

• Physical machine to VirtualCenter Server - 902

• Physical machine to ESX Server 3.x - 902

Converter 3.0.1 uses the following ports:

• Converter application to remote physical machine - 445 and 139

• Converter application to VirtualCenter Server - 443

• Converter application to ESX Server 3.x - 443

• Physical machine to VirtualCenter Server - 443

• Physical machine to ESX Server 3.x - 443

*** If you are using Converter 3.0.1 make sure you do not have a web server using port 443 while running Converter

When you select VirtualCenter as a destination and then chose a ESX host, Converter will first make a connection to VirtualCenter and then the ESX host, so you will need to make sure these ports are not being blocked for both the VirtualCenter server and ESX server

What Windows Services need to be running for Converter to work properly?

The Windows Server and TCP/IP Netbios Helper services must be running for Converter to work properly. Also for Windows 2003 Servers the Volume Shadow Copy service must not be disabled (can be Manual or Automatic)

What should I do before running Converter?

First, once you install Converter on the source system to do a Hot clone, you must reboot the system before running it. Once you reboot, make sure the Vmware Converter service is started and running before you begin. Next shutdown any un-needed Services, the less Services running the better your chances for a successful conversion. This includes backup agents, virus scanners, applications, etc.

What types of servers should not be converted?

In general, Active Directory domain controllers, database servers (SQL/Oracle), Exchange servers and any servers that have sensitive applications are not good candidates for conversions. If you do try and convert these types of servers the best method is to cold-clone them. If you must hot-clone them make sure all applications and services are shutdown before starting the conversion. Database servers are particularly sensitive to corruption when being converted. It is also best if you do not change the drive sizes when converting these servers. If you re-size hard drives this changes the copy method that Converter uses to migrate the data to the destination. Domain controllers have been known to have USN rollback problems after being converted. See the following Microsoft knowledge base articles for more information: and and also

What is the difference between the Starter and Enterprise edition of Converter?

The differences are Enterprise includes support, the ability to cold-clone with the boot CD, able to do multiple simultaneous conversions and perform remote conversions

How do I get a Enterprise license for Converter?

Vmware Converter Enterprise is available at no additional cost to existing and new VirtualCenter Management Server customers and P2V Assistant customers, with valid support and subscription contracts. First go to and click on the Manage VMware Product Licenses link. If you are entitled to Converter licenses you will see Vmware Converter 3.0 Enterprise listed once you log in. Once you activate the license and download the license file you can go to and click on the Enterprise Edition link to download the ISO file for cold-cloning. The installation program for hot-cloning is the same for Starter and Enterprise editions. Once you select a license file in Converter it will unlock the Enterprise features. One thing to note is that the license file you download for Converter does not work with the License Manager server. Even though it is in the same format as the ESX licenses the License Server will not recognize it. To use your Converter license file simply copy it to the server that Converter is installed on and launch the Converter application and select Administration, Licensing Information and click Add License and browser and select your Converter license file

Is there support available for Converter?

Support is available for the Starter edition but needs to be purchased on a per incident basis ($90 per incident). If you have the Enterprise edition support is included as part of the VirtualCenter Management Server. Also the Vmware Converter forum is a great resource for answering Converter questions and solving problems

Can I convert Linux servers with Converter?

The Converter documentation states: “Experimental support only is available for Linux-based physical to virtual machine conversions using the Vmware Converter BootCD (cold cloning) if the source physical machine has SCSI disks.” Some people have had success converting Linux machines, others have not. If Converter does not work on your Linux machine you can try a commercially available conversion product from Platespin called PowerConvert which has full Linux support.

Why are ESX and VirtualCenter grayed out as destinations when I run Converter?

If you are using the Starter edition you must run it on the physical server that is being converted for ESX Server and VirtualCenter to be available as destinations. If you do not run it on the server being converted then only the Vmware standalone virtual machine option is available. Enterprise edition does not have this restriction

Thursday, August 21, 2008



I started following Indian politics using media and internet. I am so tired of these sick news channel their insensitive journalism. I know by doing this I am inviting more controversy but I am so frustrated by these channel that I decided to blog it. Where I have full freedom and I don’t have to create account in order to write my thoughts. Either it is or they decide what they have to show to the public but on my blog I have no restriction.

Wednesday, August 20, 2008

Trying To Be Photographer Part15

Got new filter for editing black and white photo called Silver Efex Pro. Wanted to share some result

Fixing Licensing issue if evalution period of ESX host is expired

One of the server builder was trying to deploy VM using template and it was throwing message “Invalid configuration for Device 0 and sometimes device 1”.

1. Converted template back to VM and then removed CDROM and ISO image no luck.

2. Restarted “hostd” and “vpxd” on the target host but no luck.

Now I tried to deploy the VM on different host it was successful. What is going on with this target host? So I cold migrated the vm to the same host on which I was having trouble, it was successful.

Now I tried to power on the VM I got this message “There are not enough licenses installed to perform the operation”. Wow I thought everything is pointing to license server but no, someone forgets to change the licensing information for this host and it was still running under evaluation mode (Though we have license server installed).

1. Selected host view mode and then selected configuration and then “Licensed Features” and directed to our license server but it was getting timed out.


2. Thought might be license service might be stopped. Tried restarting service but it get timed out with Error -5. Thought let me try to reboot the virtual center and that may fix it. Yeah even I got alias for Virtual center ☺. Rebooted the server and I was able to restart the license server service but it use to die very soon. I thought it might be license server which I can install it again. I went to VMWare support site and download License Server for ESX3.5 and got my license server reinstalled.

3. After the license server was reinstalled license service was started for ever. Now I have got to fix the host.

4. I was tried to license again using licensed feature and still it was getting timed out. I check the license server from the console and I was not able to ping the license server using FQDN but only using IP. Now I got to fix DNS , the entry for DNS was wrong under “DNS and Routing” (Great Feature ) . Updated the DNS and now I was able to ping using FQDN but still I was not able to use either IP address or FQDN for license server.

5. OK now I did tried this Change the Host date and time to the value when it was still running under evaluation method (This trick work for most of the evaluation software ;) ). I restarted hostd and vpxd and guess what. I got the tab which says “Enable evaluation mode”. So this tricks was working to some extend but I was not able to put the host into evaluation mode.

6. I thought I will put the host into evaluation mode and then change it back to host based license.

7. It still not allowing me to put it into evaluation mode. So I thought this is the right time to contact VMWare license support. I called VMWare license support and the asked me to use host based license then convert it back to server based license.

8. This was bit risky but I told them to put back my license into the pool when I change to server based license.

9. I did same first I used their license file and register host with that file. When it was licensed then I changed it to server based license.

10. Contact VMWare support to put back the license into the pool ☺

Key is please update the license information for the host before evaluation period expire.

Sunday, August 17, 2008

Trying To Be Photographer Part14

The concrete trail is about 6.15 miles (10 kilometers) in length. The greenway runs along Big Creek parallel to North Point Parkway, from Webb Bridge Road on thenorth end to Mansell Road on the south end. A soft mulch trail encircles a large wetland between Haynes Bridge Road and Mansell Road. Wildlife such as blue heron, deer, ducks and Canadian geese can be observed in this preserved water setting.

Online Videos by

Saturday, August 16, 2008

Trying To Be Photographer Part13

How is this ?

F Stop : F/2.8 Exposoure Time : 1/13sec Focal Lenght :33mm Max Aperture :2.96875

ISO Speed :100

Friday, August 15, 2008

India Turns 61 today

Happy Independence Day Dear India
INDIA which has 31 states, 1618 languages, 6400 castes, 6 religions, 6 ethnic groups, 29 major festvals, but still one country .
Here is the cute Pug who wishes us Happy Independence Day

Wednesday, August 13, 2008

Not able to connect to network Share

After implementing VLAN trunking users run into strange problem. They were getting following error message when try to get share using UNC path \\<machine name>\c$ .


I have started following services and perform these action

1. Computer Browser

2. DNS

3. netlogin

4. Reinstall File and print services.

5. Reinstall TCP/IP

But none of this was helping. I checked again with network engineer and they told every thing is fine from VLAN prospective. Some user told they are and some were not. I mean I was not able to understand why some can and why some can not. This has something to do with network. When I moved to different VLAN UNC path started working. After discussion with Network guy we came to conclusion that VLAN was used for different purpose and may have some access list which might be blocking RPC server. But now user came with different problem while doing RDP


I was wondering now what went wrong and here came the answer from VMWare Community so I did the following

1. Remove it from the domain

2. Uninstall the VMtools. If you try to uninstall before removing it from the Domain you will get all kind of wired messages.

3. Join back the domain.

4. Reinstall the tool using costume method. There is also some issue with full install of VM tool

Friday, August 8, 2008

Awesome performance in Beijing 2008 Olympics

I was trying to find how was the Beijing Olympics opening ceremony went of and found amazing video where the performer is showing amazing art which is mixed with perfection, balance, strength ,flexibility. I was watching this alone in the morning and could not resist to shout "Awesome" . This is "Must to Watch " video. The nice part of entire show was when he tried to balance the other guy on his head. Can you believe it ?

Trying To Be Photographer Part12

Well here is my next photo which I shot during my trip to Smokey. I liked the shot and here are the details about the shot
Focal Length : 16mm
Exposure Time: 1/4000
ISO: 800
Metering Mode : Matrix
Aperture :f/2.8

Backup Plan

Datalink presents the official movie trailer for the upcoming "The Backup Plan III." Background: In 1997, Glen Hader blew off his backup and recovery meeting with information storage architect Datalink. In 2007, Glen's luck finally ran out. Watch as Glen's day goes from bad to worse in this compelling story ripped from today's headlines.

Thursday, August 7, 2008

Trying To Be Photographer Part11


On 4th of July myself along with Bikas,Debu,Mansi,Suman,Partho and Anurag started for Great Smokey Mountains. We had two cars and along with that we had two full time (Vikash/Debu) and two part time drivers (Bikas/Suman). We went to see places like Fountana Dam,Cligmans Dome,Cades Cove and Abrams Falls. We booked Hous of Dream from Volunteer Cabin Rental .It was a nice little apartment with all the facilities like Jacuzzi, HDTV,DISH,BILLIARDS and nice living room. We had a nice time there. We return back on 6th of July after driving around 1000 Miles.

Online Videos by

Wednesday, August 6, 2008

Lesson and experience- Implementing VLAN trunking

For past couple of weeks I was trying to solve IP address issue. We have host with DL380 and DL385 which were underutilized. Network engineer gave me couple of VLAN and told me to use. I tried to explain that these VLAN is not good for me until we have VLAN trunked on the physical switch port. It started with formal discussion and then it went to support request with VMWare. VMWare tech support asks us to follow following KB’s 1004074 and 1004127. Our network engineer followed exactly the same way as narrated in 1004074 but he forget to put the port into trunked mode and traffic was not able to pass through another VLAN but only through native VLAN. So what is the Native VLAN? It is like when you install ESX without any VLAN info it mark the network as “VM Network” and your switch configuration looks like this

interface GigabitEthernet1/29


switchport access vlan 2

switchport mode access

no ip address

no snmp trap link-status

spanning-tree portfast


This is native VLAN and traffic does not get tagged when ESX host pass the traffic to the physical switch.


So in the above example it was very easy since I had two NIC and even I lose connectivity of my VM’s while implementing VST then I still connection over my management console (Service Console). After speaking to VMWware tech support who was really good in explaining about VMWare networking. Here is how he explained.

He also forwarded couples of KB’s 1003825,1004088,1004048,1004252 and 1004127 to some extend it was helpful. After understanding the KB we have implemented on one of the host which is on above pics and it was successful. We thought we were confident to implement across the environment but no we were wrong. Why we were wrong? Because the other host were has their unique wiring. What was unique about it? The service console and VM Network on the single NIC. Yeah I know it sounds so stupid as per standard VMWare practice but again that is the reason I am here or else why anyone need my service.

Our next show started when we thought of implementing on the host with single NIC


Again I planned to test on this host along with my Network engineer. He verified and the configuration looks like this

interface GigabitEthernet1/29


switchport access vlan 2

switchport mode access

no ip address

no snmp trap link-status

spanning-tree portfast


and then he tried to wipe it out the configuration and then enter

interface GigabitEthernet2/9

description xxxxxxxx


switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-3,5,224

switchport mode trunk

switchport nonegotiate

no ip address

no snmp trap link-status

no cdp enable

spanning-tree portfast trunk


(DON’T worry about description it would vary from environment to environment)

When he was trying to write the configuration back to IOS on the switch it was not accepting the command switchport trunk encapsulation dot1q . With this we have to stop the changes and role it back to as it was traffic was back to original state. Every one was scratching their head is it fault from VMWare side or it is the network. Why the heck it does not accept switchport trunk encapsulation dot1q . I also did some research and guessed that it may be because both the management VLAN and console VLAN is on the same port that might be causing the issue. So I told my network folks to roll back the changes and let me try something. I thought I would label original “Service Console” to have it on VLAN2 (VM Network was on VLAN 2) but it gave me warning and I landed up in creating another “Service Console “ and assigning different IP address to it but still no luck. I had been asked to call VMware tech support guy and have conference with Network folks. My network engineer came back online and he was able to trunk the VLAN’s over the port but I my host was kicked out of the network. At this point VMWare tech support asked me to get the ILO session and asked me to run esxcfg-vswitch –l . Following was the output

You can see that VM Network and Service Console are on VLAN 0 so when you run the following command

interface GigabitEthernet2/9

description xxxxxxxx


switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-3,5,224

switchport mode trunk

switchport nonegotiate

no ip address

no snmp trap link-status

no cdp enable

spanning-tree portfast trunk


Service Console also comes into VLAN 2 (Original Service Console IP address is the part of the VLAN 2). So VMWare tech support asked me to lable the existing service console to VLAN 2 using following command esxcfg-vswitch –p “Service Console” –v 2 vSwitch0 BINGO my host got back into network. He also deleted my newly created service console using esxcfg-vswitch –D “Service Console2” vSwitch0. We thought this is the process of implementing the VLAN trunking. So I scheduled another downtime to implementing VLAN trunking on some of the production host. Again when we started implementing on the host our network engineer had trouble passing the command switchport trunk encapsulation dot1q and I was kind of stuck. Everyone was behind my as*** since I have asked for second downtime in two days.

Our network folks called their support and those guys figured out that Service Console is on VLAN 0 which is in NATIVE state and that is the reason it is not allowing to pass the command switchport trunk encapsulation dot1q ,I was kind of shocked why does switch will not allow to make changes if NIC on the host is in Native MODE.

It was very important to note that when you are making the changes as per “FIG Situation 2” we have to make changes on the host level first and then network engineer will make the configuration changes. So that steps would be

  1. Open the Putty session and run the following command to label the “Service Console” as per the original IP address using following command

esxcfg-vswitch –p “Service Console” –v 2 vSwitch0

  1. And then Network Engineer would be making the changes only after stripping everything out of the switch port

interface GigabitEthernet2/9

description xxxxxxxx


switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-3,5,224

switchport mode trunk

switchport nonegotiate

no ip address

no snmp trap link-status

no cdp enable

spanning-tree portfast trunk


If the steps are not followed in the same way port trunking will never WORK. I have read so many blogs from Scott Lowe and many KB but no were people has experienced something like this. Well no I claim that I am above Scott Lowe or anyone but it was real good experience for me.

Friday, August 1, 2008

Force Virtual Machine on ESX to boot into BIOS

I was trying to figure out how can we force boot the Virtual machine into BIOS mode. When VM’s is powered boot screen changes so fast that you can not even see the text. It directly goes into PXE. Some blogger suggested to make changes in VMX file so that it can force it to go into BIOS. Why I wanted to go into BIOS ? Because I wanted to boot it through ISO but for some reason it was not. ISO was also bad for some reason. It was not a big thing but was talking long time to figure out. I also learned that either ESC or F12 Key can also help VM to boot into BIOS.

Finally there were settings on then VM itself which will boot the machine into BIOS. But this setting has to be set every time when VM has to booted into BIOS.

Trying to Photographer Part10

Here is my other creation

Trying to be Photographer Part9

Bowling club get together

While leaving my previous work place I had a great time. Some moments to share with every one who visit my blogs and also to show them that I have started learning “Movies making”